Windows 7 y 8 TLS

Ya hace tiempo tengo varios usuarios que tienen problemas con su correo outlook al intentar conectarse a su cuenta, mas correctamente no es que no este funcionando el servidor o tenga problemas el outlook mas que nada es un problema a nivel sistema operativo ya que la cuenta, contraseña y todos los datos necesarios están bien, sin embargo les da un error de “método de conexión” y esto se debe principalmente a que usan Windows 7 o Windows 8 y en estos sistemas el TLS por defecto que utilizan es el 1.0 cuando el servidor (comúnmente los servidores mas actualizados y modernos) utilizan 1.1, 1.2 o 1.3 por lo cual jamas dejaran conectar a una versión anterior a esa.

Este problema lo he visto en cPanel desde la versión 68 que es a partir de ahí que cPanel configura todos los servidores con TLS 1.2 por defecto, entonces si te presenta este problema de la nada puede que tu proveedor o tu actualizase cPanel y cambio esto.

¿Bueno Oscar ya nos explicaste el porque no funciona pero como supiste? La verdad no todo es gracias a mi ya saben como funciona el internet tenia un problema que investigue y encontré gente con el mismo problema que me corroboraron mis sospechas, encontré dos maneras de solucionarlo con una mexicanada o su homologo anglosajon “workaround” y la otra educando al usuario.

Referencia 1: https://blogs.technet.microsoft.com/schrimsher/2016/07/08/enabling-tls-1-1-and-1-2-in-outlook-on-windows-7/

Referencia 2: https://documentation.cpanel.net/display/CKB/How+to+Adjust+Cipher+Protocols

La primer referencia es la opción mas adecuada, educar al usuario a actualizar sus sistemas y parches de seguridad, no solo por los problemas corregidos si no para no darles dependencia a uno y no comprometer el servidor por unos pocos usuarios.

La segunda referencia indica que hay que hacer unos cambios en los protocolos de seguridad del servidor para que los usuarios no lo recientan pero la verdad esto generara mas problemas a futuro así que depende de ustedes.

En los foros de cPanel no encontré ningún post haciendo referencia a la actualización de la referencia 1 así que espero le sirva a alguien mas, es mas tedioso pero pueden decirle a sus clientes “ocupas x actualización de seguridad en tus sistemas” e igual les sirve mas a ellos, pues no solo es para outlook si no para Internet Explorer y https en general y cualquier aplicaciones que requiera una version mas actualizada a la tls 1.0 incluso el soporte del tls 1.0 creo que ya esta a punto de expirar.

Got Something To Say?

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *